修复 tornadoredis 兼容 tornado5.1

 写在最前头,tornadoredis 这玩意BUG颇多,个人不建议使用,只是记录一下修改过程。

主要兼容 tornado5.1 因为这个版本删掉了io_loop所以会造成引用时候报错找不到 io_loop.

@tornado.web.asynchronous
@tornado.gen.engine
修改为:

@tornado.gen.coroutine

 

\Python27\Lib\site-packages\tornadoredis\connection.py

大约75行吧,因为bug多自己修改了一下具体还是搜索下面代码为准:
self._stream = IOStream(sock, io_loop=self._io_loop)
修改为:
self._stream = IOStream(sock)

发表评论

您的电子邮箱地址不会被公开。