xcrun: error: SDK “iphonesimulator” cannot be located 解决办法

执行  /usr/bin/xcrun –sdk iphonesimulator –show-sdk-path 命令的时候提示以下错误

xcrun: error: SDK "iphonesimulator" cannot be located
xcrun: error: SDK "iphonesimulator" cannot be located
xcrun: error: unable to lookup item ‘SDKVersion’ in SDK ‘iphonesimulator’

 

我的解决办法,启动 Xcode 找菜单项

Xcode – Preferences… -> Locations 选项卡下

Command Line Tools: 选择一下你现在用的 Xcode 版本 最后保存

当然我事先安装了 Components 选项卡,我事先安装了Simulators 选择一个你需要的ios 版本,不知道跟这个有关系没。

发表评论

您的电子邮箱地址不会被公开。