易语言实现 escape unescape 函数代码

.版本 2

.子程序 Crypt_ESCAPE, 文本型, 公开
.参数 str, 文本型
.参数 是否解密, 逻辑型, 可空
.局部变量 Script, 对象

Script.创建 (“MSScriptControl.ScriptControl”, )
Script.写属性 (“Language”, “JavaScript”)
返回 (Script.通用方法 (“Eval”, 选择 (是否解密, “unescape”, “escape”) + “(” + #引号 + str + #引号 + “)”).取文本 ())
 

发表评论

您的电子邮箱地址不会被公开。